Kinetic - Americas Service Issue

Incident

Kinetic - Americas Service Issue

Status: closed
Start:
End:
Duration: 2 hours 12 minutes
Affected Components:
Kinetic (formerly Epicor ERP Cloud) Kinetic - Americas
Update

Epicor's Kinetic - Americas is currently experiencing a disruption that is impacting a subset of Customers and you could be impacted by this issue.

All appropriate support teams are engaged in troubleshooting and restoring services as quickly as possible.

Update

Epicor's Kinetic - Americas region is still experiencing a disruption and you could be impacted by this issue. All appropriate parties are engaged to restore functionality and determine the root cause. 

Resolved

Service issue affecting a subset of Kinetic - Americas customers has been resolved. we apologize for the inconvenience.